Steven JW Kennedy

My Blog

Archive for December 15th, 2010

Missing Server Side Dependencies – 8d6034c4-a416-e535-281a-6b714894e1aa

Posted by Steven Kennedy on December 15, 2010


(First posted on my web.me.com/stevenjkennedy blog on 9th October 2010)

Information configuration issue;

[MissingWebPart][WebPart class [8d6034c4-a416-e535-281a-6b714894e1aa] is referenced [6] times in the database, but is not installed on the current farm. Please install any feature/solution which contains this web part. One or more web parts are referenced in the database, but are not installed on the current farm. Please install any feature or solution which contains these web parts.] 

There is a blog entry here, that talks about how to ‘fix’ this problem. I tried it and it worked for me. The information given, visit the two web pages SearchAdministration.aspx and SearchFarmDashboard.aspx worked only there where no directions on how to get to the two pages. I had to go searching (pun intended) for them, checking the URL address until I found them.

Having visited each page I then went back to the SharePoint Centralized Administration and re-checked to see if the issue was still showing up. It wasn’t.

So where where these pages? Well SearchFarmDashboard.aspx is accessed via Central Administration.General Application Settings.Farm Search Administration, as shown in the pictures.

image_2_36F31C30

image_4_36F31C30

The page SearchAdministration.aspx can be accessed by clicking on Search Service Application. The resulting page is shown below.

image_6_36F31C30

Advertisements

Posted in SharePoint 2010 | Tagged: | Leave a Comment »