Steven JW Kennedy

My Blog

Archive for January 25th, 2011

Must remember to set outbound SMTP port

Posted by Steven Kennedy on January 25, 2011


Part of my home network includes an an Exchange 2010 server, that I use to look at the features & functions of Exchange. However, when trying to send email from home it’s a bit hit or miss as to whether it’s received at the other end. This is largely due to the other email systems not liking the IP address from which my email is sent, it’s a Verizon TCP/IP address. Seems a lot of the address Verizon uses for home are on various Black Lists.

So, I signed up for DynDNS’s Send mail capability, called Sendlabs SMTP. This allows be to send email via DynDNS. The recipients email system therefore sees the source as DynDNS so as long as DynDNS isn’t Black Listed I’m okay.

As there is also the possibility that my Internet provider, Verizon FIOS, could decide to block outbound traffic on port 25 I setup Sendlabs SMTP to use an alternate port.

The thing to remember is to set the outbound SMTP connector in Exchange to that alternate port, which I didn’t remember to do.

I’d an issue with my outbound email and as part of the fix I had to re-do my Edge Synchronization which entailed re-creating both the Inbound and outbound connectors. Note! because I’m using Edge Synchronization all of the configuration for the send and receive connectors is done on the Hub Transport server, NOT the Edge Transport server.

DynDNS have the steps for configuring the outbound connector using both the Exchange Management Console (EMC) and the Exchange Management shell. As my send connector already existed, it’s created automatically when using Edge Subscription, I only had to update the send connector to point to DynDNS’s mail hop URL and provide the appropriate credentials.

With the EdgeSync connector Properties page open select the Network tab. Select the radio button Route mail through the following smart hosts: and then click on Add

EdgeSync Connector Properties

Click on the radio button Full qualified domain name (FQDN) and type in the name of the smart host, in this case the DynDNS smart host, outbound.mailhop.org. Click on OK

Add smart host

You’ll be taken back to Network tab, as shown above. Now click on the Change button. In the subsequent dialog box select Basic Authentication AND Basic Authentication over TLS (not shown in picture). Then enter your DynDNS user name and password. Click on OK to complete the configuration.

Smart host authentication settings

Having done that I still needed to update the SMTP port, but I couldn’t find anywhere to do that using the console. Instead I had to use the Exchange Management Shell and issue the command;

set-sendconnector “connector name” – Port <alternate port number>

after which you need to either wait for or force an update of the Edge Synchronization. You can do so using;

Start-edgesynchronization

So in my particular case the two commands were;

set-sendconnector “EdgeSync – Default-First-Site-Name to Internet”  -Port 2525

Start-edgesynchronization

Posted in Exchange 2010 | Tagged: , | Leave a Comment »

‘Droid email problem

Posted by Steven Kennedy on January 25, 2011


I’ve had a ‘Droid for approximately 6 months now. I have Gmail setup on it, and it’s working fine, and I also have my Verizon email account, using the ‘Droid Email app.

Everything seemed to be okay for a while and then I started to notice that when I went in to the ‘Droid Email it would show a spinning icon, as if it was trying to connect to my Verizon account. It would just sit there. Eventually I ended up powering off the ‘Droid and turning it back on. When I did so the Email app would connect to my Verizon account okay and download any waiting email.

This has now become tedious. I’ve checked a few forums and it would seem that I’m not the only one seeing this issue. One post I saw indicated that their ‘Droid Email would work for something like 24-48hrs and then would ‘hang’ as I’ve described above. So far I haven’t seen a fix for this issue.

I’ll do some more sleuthing to see if anyone has a fix out there. Failing that I’ll see if there’s a ‘better’ email app out there for use with Internet email accounts. In the mean time I’ll be powering off and on my ‘Droid on a regular basis.

Posted in Android | Tagged: , | 1 Comment »